OSPF Network Types

Different media can provide different characteristics or might limit the number of nodes allowed on a segment. Frame Relay and Ethernet are common multi-access media, and because they support more than two nodes on a network segment, the need for a DR exists. Other network circuits, such as serial links, do not require a DR.

The default OSPF network type is set based on the media used for the connection and can be changed independently of the actual media type used.

Type Description DR/BDR Field in Hellos Timers

Broadcast

Default setting on OSPF-enabled Ethernet links.

Yes

Hello: 10
Wait: 40
Dead: 40

Non-Broadcast

Default setting on OSPF-enabled FR main interface or FR multipoint sub-interfaces.

Yes

Hello:30
Wait:120
Dead:120

Point-to-Point

Default setting on OSPF-enabled FR P2P sub-interfaces

No

Hello:10
Wait:40
Dead:40

Point-to-Multipoint

Not enabled by default on any interface type.
Primarily used for hub-and-spoke topologies.

No

Hello:30
Wait:120
Dead:120

Loopback

Default setting on OSPF-enabled loopback interfaces.
Interface is advertised as a host route /32.

N/A

N/A

Broadcast

  • Broadcast media such as Ethernet are better defined as broadcast multi-access to distinguish them from non-broadcast multi-access (NBMA) networks.
  • Broadcast networks are multi-access in that they are capable of connecting more than two devices, and broadcasts sent out one interface are capable of reaching all interfaces attached to that segment.
  • The OSPF network type is set to broadcast by default for Ethernet interfaces.
  • A DR is required for this OSPF network type because of the possibility that multiple nodes can exist on a segment, and LSA flooding needs to be controlled.
  • The hello timer defaults to 10 seconds, as defined in RFC 2328.

Non-Broadcast

  • Frame Relay, ATM, and X.25 are considered nonbroadcast multi-access (NBMA) in that they can connect more than two devices, and broadcasts sent out one interface might not always be capable of reaching all the interfaces attached to the segment.
  • Frame Relay interfaces set the OSPF network type to nonbroadcast by default.
  • The hello protocol interval takes 30 seconds for this OSPF network type.
  • Multiple routers can exist on a segment, so the DR functionality is used.
  • Neighbors are statically defined with the neighbor ip-address command because multicast and broadcast functionality do not exist on this type of circuit.
  • Configuring a static neighbor causes OSPF hellos to be sent using unicast.

Point-to-Point Networks

  • A network circuit that allows only two devices to communicate is considered a point-to-point (P2P) network.
  • Because of the nature of the medium, point-to-point networks do not use Address Resolution Protocol (ARP), and broadcast traffic does not become the limiting factor.
  • The OSPF network type is set to point-to-point by default for serial interfaces (HDLC or PPP encapsulation), generic routing encapsulation (GRE) tunnels, and point-to-point Frame Relay subinterfaces.
  • Only two nodes can exist on this type of network medium, so OSPF does not waste CPU cycles on DR functionality.
  • The hello timer is set to 10 seconds on OSPF point-to-point network types.
  • Interfaces using an OSPF P2P network type form an OSPF adjacency more quickly because the DR election is bypassed, and there is no wait timer.
  • Ethernet interfaces that are directly connected with only two OSPF speakers in the subnet could be changed to the OSPF point-to-point network type to form adjacencies more quickly and to simplify the SPF computation.
  • The interface parameter command ip ospf network point-to-point sets an interface as an OSPF point-to-point network type.

Point-to-Multipoint Networks

  • The OSPF network type point-to-multipoint is not enabled by default for any medium. It requires manual configuration.
  • A DR is not enabled for this OSPF network type, and the hello timer is set 30 seconds.
  • A point-to-multipoint OSPF network type supports hub-and-spoke connectivity while using the same IP subnet and is commonly found in Frame Relay and Layer 2 VPN (L2VPN) topologies.
  • The IOS interface parameter command ip ospf network point-to-multipoint manually sets an interface as an OSPF point-to-multipoint network type.
R1
interface se0/0
 encapsulation frame-relay
!
interface Serial 0/0.123 multipoint
 ip address 10.123.1.1 255.255.255.248
 frame-relay map ip 10.123.1.2 102 broadcast
 frame-relay map ip 10.123.1.3 103 broadcast
 ip ospf network point-to-multipoint
!
router ospf 1
 router-id 192.168.1.1
 network 0.0.0.0 255.255.255.255 area 0
R2
interface Serial 0/0
 encapsulation frame-relay
!
interface Serial 0/1/0/0.123 multipoint
 ip address 10.123.1.2 255.255.255.248
 frame-relay map ip 10.123.1.1 201 broadcast
 ip ospf network point-to-multipoint
!
router ospf 1
 router-id 192.168.2.2
 network 0.0.0.0 255.255.255.255 area 0
R1# show ip ospf interface Serial 0/0.123 | include Type
  Process ID 1, Router ID 192.168.1.1, Network Type POINT_TO_MULTIPOINT, Cost: 64
R2# show ip ospf interface Serial 0/0.123 | include Type
  Process ID 1, Router ID 192.168.2.2, Network Type POINT_TO_MULTIPOINT, Cost: 64
R1# show ip ospf neighbor

Neighbor ID     Pri     State        Dead Time       Address         Interface
192.168.3.3       0   FULL/ -         00:01:33    10.123.1.3     Serial0/0.123
192.168.2.2       0   FULL/ -         00:01:40    10.123.1.2     Serial0/0.123
R2# show ip ospf neighbor

Neighbor ID     Pri     State        Dead Time       Address         Interface
192.168.1.1       0   FULL/ -         00:01:49    10.123.1.1     Serial0/0.123

Loopback Networks

  • The OSPF network type loopback is enabled by default for loopback interfaces and can be used only on loopback interfaces.
  • The OSPF loopback network type states that the IP address is always advertised with a /32 prefix length, even if the IP address configured on the loopback interface does not have a /32 prefix length.

Summary

OSPF Network Types

  • Broadcast
  • Non-broadcast
  • Point-to-Point
  • Point-to-Multipoint
  • Point-to-Multipoint Non-broadcast
  • Loopback
  • OSPF’s behavior changes depending on what type of media it is configured on.
    • Ethernet vs FR vs PPP
  • OSPF defines different “network types” to deal with different media characteristics
  • OSPF network types control…
    • How are hellos & updates sent?
    • Who forms adjacency?
    • How is the next-hop calculated?
  • OSPF network type does not need to match to form adjacency…
    • but they do need to be compatible
    • other attributes must still match (timers)
  • What makes the network types compatible?
    • Usage of Type 2 LSA

LSA Type 2 – Network LSA

  • Generated by the DR
    • describes who is adjacent with DR
    • not flooded outside the area they originate in
  • Used to optimize OSPF operation on a shared segment
    • reduce number of OSPF adjacencies
    • reduces LSA flooding
    • Simplify SPF calculation

Network types that use Type 2 SLA

  • Broadcast
  • Non-broadcast

Network types that do not use Type 2 LSA

  • Point-to-Point
  • Point-to-Multipoint
  • Point-to-Multipoint Non-broadcast

Broadcast

  • Default on multi-access broadcast medias
    • Ethernet
  • Sends hellos and updates as multicast
    • 224.0.0.5 AllSPFRouters
    • 224.0.0.6 AllDRouters
  • Uses DR & BDR
    • uses Type 2 LSA

Non-Broadcast

  • Default on multipoint NBMA medias
    • Frame-relay & ATM
  • Sends hellos as unicast
    • Manually defined addresses with neighbor command
  • Uses DR & BDR
    • uses Type 2 LSA

Point-to-Point

  • Default on P2P medias
    • HDLC, PPP, GRE
  • Sends hellos as multicast
    • 224.0.0.5
  • No DR/BDR election
  • Supports only two neighbors on the link

Point-to-Multipoint

  • Treat network as a collection of P2P links
  • Sends hellos as multicast
    • 224.0.0.5
  • No DR/BDR election
  • Special next-hop processing
  • Best design option for partial mesh NBMA networks

Point-to-Multipoint Non-Broadcast

  • Same as point-to-multipoint, but sends hellos as unicast, requires static peers
    • Manually defined addresses with neighbor command
  • No DR/BDR election
  • Special next-hop processing

DR & BDR

  • DR
    • Forms adjacency with all routers on the segment
    • Listen for LSUs (224.0.0.6)
    • Re-floods LSUs back to the segment (224.0.0.5)
    • Doesn’t modify next-hop
  • BDR
    • Used for redundancy of DR
  • DROTHER
    • All other routers on the segment
    • Form FULL adjacency with DR and BDR
    • Stop at 2-WAY state with each other

DR / BDR Election

  • Chosen thru election process
  • Election based on interface priority and RID
    • Priority
      • 0 – 255
      • Higher is better
      • 0 = never
  • RID
    • Highest loopback / interface IP
    • Can be set statically
    • Higher is better

Leave a Reply

Related Post

OSPF LSA TypesOSPF LSA Types

Link-State Announcements When OSPF neighbors become adjacent, the LSDBs synchronize between the OSPF routers. As an OSPF router adds or removes a directly connected network link to or from its